$re = '/^(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])(?=[ a-zA-Z\d-]*[^ a-zA-Z\d-])\D*\d/m';
$str = 'aBcD123
Aa1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);