using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(100%|\d+)x(100%|(\d+(?!\%|\d)))";
string input = @"100x10
100%x100
99x99
99%x100
99x99%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}