$re = '/(100%|\d+)x(100%|(\d+(?!\%|\d)))/m';
$str = '100x10
100%x100
99x99
99%x100
99x99%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);