#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\/\d+\/\d+\s*?\d+:\d+:\d+\s*?[AP]M"
Local $sString = "12345 User Name 9/10/2018 11:39:37 AM Valid Entry Place1 " & @CRLF & _
"12345 User Name 9/10/2018 12:48:43 PM Valid Exit Outside Place1 " & @CRLF & _
"12345 User Name 9/10/2018 1:00:44 PM Valid Entry Place1 " & @CRLF & _
"12345 User Name 9/10/2018 2:17:01 PM Valid Exit Outside Place1 " & @CRLF & _
"12345 User Name 9/10/2018 3:23:36 PM Valid Entry Place1 " & @CRLF & _
"12345 User Name 9/10/2018 3:25:56 PM Valid Entry Place1 " & @CRLF & _
"12345 User Name 9/10/2018 6:06:25 PM Valid Exit Outside Place1 " & @CRLF & _
"12345 User Name 9/10/2018 6:07:55 PM Valid Entry LC " & @CRLF & _
"12345 User Name 9/10/2018 6:28:19 PM Valid Exit Outside LC " & @CRLF & _
"12345 User Name 9/10/2018 6:30:06 PM Valid Entry Place1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")