import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\/\\d+\\/\\d+\\s*?\\d+:\\d+:\\d+\\s*?[AP]M";
final String string = "12345 User Name 9/10/2018 11:39:37 AM Valid Entry Place1 \n"
+ "12345 User Name 9/10/2018 12:48:43 PM Valid Exit Outside Place1 \n"
+ "12345 User Name 9/10/2018 1:00:44 PM Valid Entry Place1 \n"
+ "12345 User Name 9/10/2018 2:17:01 PM Valid Exit Outside Place1 \n"
+ "12345 User Name 9/10/2018 3:23:36 PM Valid Entry Place1 \n"
+ "12345 User Name 9/10/2018 3:25:56 PM Valid Entry Place1 \n"
+ "12345 User Name 9/10/2018 6:06:25 PM Valid Exit Outside Place1 \n"
+ "12345 User Name 9/10/2018 6:07:55 PM Valid Entry LC \n"
+ "12345 User Name 9/10/2018 6:28:19 PM Valid Exit Outside LC \n"
+ "12345 User Name 9/10/2018 6:30:06 PM Valid Entry Place1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}