$re = '/£(?:1(?:[0-4](?:[0-9]?(?:[.,][0-9]{1,2})?)?|5(?:[0-4](?:[.,][0-9]{1,2})?|5(?:[.,]00?)?)|[6-9]?(?:[.,][0-9]{1,2})?)?|[2-9][0-9]?(?:[.,][0-9]{1,2})?)(?![.,]?[0-9])/mx';
$str = '£155.12
£155
£1
£124,44';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);