const regex = /<(\w+)([^>]*)>(.*)(\s*)(<\/\1>$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)([^>]*)>(.*)(\\s*)(<\\\/\\1>$)', 'gm')
const str = `<HTML lang="ko">
<BODY>
</BODY></HTML>
<HTML lang="ko">
<BODY>
<P>BOOST
</P>
</BODY></HTML>
<body></body>
<!DOCTYPE html>
<HTML lang="ko">
<BODY>
<P>BOOST<IMG SRC="codesquad.kr"></IMG>
<BR/></P>
<FONT name="Seoul">CAMP</FONT>
</BODY></HTML>
<?xml version="1.0" encoding="utf-8"?>
<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
android:layout_width="match_parent"
android:layout_height="match_parent"
android:orientation="vertical" >
<TextView android:id="@+id/text"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:text="Hello, I am a TextView" />
<Spacer>blank</Spacer>
<Button android:id="@+id/button"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:text="Hello, I am a Button" />
</LinearLayout>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}