import re
regex = re.compile(r"<(\w+)([^>]*)>(.*)(\s*)(<\/\1>$)", flags=re.MULTILINE)
test_str = ("<HTML lang=\"ko\">\n"
" <BODY>\n\n\n"
" </BODY></HTML>\n\n\n"
"<HTML lang=\"ko\">\n"
" <BODY>\n"
" <P>BOOST\n"
" </P>\n\n"
" </BODY></HTML>\n"
"<body></body>\n\n"
"<!DOCTYPE html>\n"
"<HTML lang=\"ko\">\n"
" <BODY>\n"
" <P>BOOST<IMG SRC=\"codesquad.kr\"></IMG>\n"
" <BR/></P>\n"
" <FONT name=\"Seoul\">CAMP</FONT>\n"
" </BODY></HTML>\n\n"
"<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<LinearLayout xmlns:android=\"http://schemas.android.com/apk/res/android\"\n"
" android:layout_width=\"match_parent\"\n"
" android:layout_height=\"match_parent\"\n"
" android:orientation=\"vertical\" >\n\n"
" <TextView android:id=\"@+id/text\"\n"
" android:layout_width=\"wrap_content\"\n"
" android:layout_height=\"wrap_content\"\n"
" android:text=\"Hello, I am a TextView\" />\n"
" <Spacer>blank</Spacer>\n"
" <Button android:id=\"@+id/button\"\n"
" android:layout_width=\"wrap_content\"\n"
" android:layout_height=\"wrap_content\"\n"
" android:text=\"Hello, I am a Button\" />\n"
"</LinearLayout>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")