re = /Expand\n\w+(\s)?,\s(\w+)(\s)?/m
str = 'Expand
Bohrer, Phyllis
Expand
Bohrer , Phyllis
Expand
Bohrer , Phyllis ,
Expand
Bohrer, Phyllis ,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end