package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){{flag\|[a-z|A-Z\s]+}}`)
var str = `| 152||data-sort-value="4"|{{Increase}} 4||{{flag|Syria}}||3.462||data-sort-value="0.393"|{{increase}} 0.393||0.777||0.396||0.501||0.082||0.494||0.151||1.062
| 153||data-sort-value="-4"|{{decrease}} -4||{{flag|Tanzania}}||3.349||data-sort-value="-0.317"|{{decrease}} -0.317||0.511||1.042||0.365||0.390||0.354||0.066||0.621
| 154||data-sort-value="3"|{{Increase}} 3||{{flag|Burundi}}||2.905||data-sort-value="0.000"|{{steady}} 0.000||0.092||0.630||0.152||0.060||0.204||0.084||1.683
| 155||NA||{{flag|Central African Republic}}||2.693||NA||0.000||0.000||0.019||0.271||0.281||0.057||2.066
|{{flagicon|Kosovo}} ''[[Kosovo]]'' <ref name="KOS" group=Note>{{Kosovo-note}}</ref>
|{{flagicon|Somaliland}} [[Somaliland|Somaliland region]]
|{{flagicon|Palestine}} ''[[Palestinian Territories]]''{{refn|See the following on statehood criteria:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}