# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{{flag\|[a-z|A-Z\s]+}}"
test_str = ("| 152||data-sort-value=\"4\"|{{Increase}} 4||{{flag|Syria}}||3.462||data-sort-value=\"0.393\"|{{increase}} 0.393||0.777||0.396||0.501||0.082||0.494||0.151||1.062\n"
"| 153||data-sort-value=\"-4\"|{{decrease}} -4||{{flag|Tanzania}}||3.349||data-sort-value=\"-0.317\"|{{decrease}} -0.317||0.511||1.042||0.365||0.390||0.354||0.066||0.621\n"
"| 154||data-sort-value=\"3\"|{{Increase}} 3||{{flag|Burundi}}||2.905||data-sort-value=\"0.000\"|{{steady}} 0.000||0.092||0.630||0.152||0.060||0.204||0.084||1.683\n"
"| 155||NA||{{flag|Central African Republic}}||2.693||NA||0.000||0.000||0.019||0.271||0.281||0.057||2.066\n"
"|{{flagicon|Kosovo}} ''[[Kosovo]]'' <ref name=\"KOS\" group=Note>{{Kosovo-note}}</ref>\n"
"|{{flagicon|Somaliland}} [[Somaliland|Somaliland region]]\n"
"|{{flagicon|Palestine}} ''[[Palestinian Territories]]''{{refn|See the following on statehood criteria:")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.