const regex = /^(?!.*47368.).*47368$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*47368.).*47368$', 'gm')
const str = `localhost:47368
localhost:47368/abc
localhost:47368/abc/47368
123:47368
123:47368/abc
123:47368/abc/47368`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}