$re = '/^(?!.*47368.).*47368$/m';
$str = 'localhost:47368
localhost:47368/abc
localhost:47368/abc/47368
123:47368
123:47368/abc
123:47368/abc/47368';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);