package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/[^\s]*`)
var str = `текст текст https://toster.ru/question/new/?get любой текст`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}