const regex = /^\s*($|#|\w+\s*=|(\?|\*|(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?(?:,(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?)*)\s+(\?|\*|(?:[0-5]?(?:\d|\*))(?:(?:-|\/|\,)(?:[0-5]?\d))?(?:,(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?)*)\s+(\?|\*|(?:[01]?(?:\d|\*)|2[0-3])(?:(?:-|\/|\,)(?:[01]?\d|2[0-3]))?(?:,(?:[01]?\d|2[0-3])(?:(?:-|\/|\,)(?:[01]?\d|2[0-3]))?)*)\s+(\?|\*|(?:0?[1-9]|[12]\d|3[01]|\*)(?:(?:-|\/|\,)(?:0?[1-9]|[12]\d|3[01]))?(?:,(?:0?[1-9]|[12]\d|3[01])(?:(?:-|\/|\,)(?:0?[1-9]|[12]\d|3[01]))?)*|(?:L)|(?:LW)|(?:L-(?:[0-9]|1\d|2\d|30))|(?:\dW|1\dW))\s+(\?|\*|(?:[1-9]|1[012])(?:(?:-|\/|\,)(?:[1-9]|1[012]))?(?:L|W)?(?:,(?:[1-9]|1[012])(?:(?:-|\/|\,)(?:[1-9]|1[012]))?(?:L|W)?)*|\?|\*|(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?(?:,(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)*)\s+(\?|\*|(?:[1-7])(?:(?:-|\/|\,|#)(?:[1-7]))?(?:L)?(?:,(?:[1-7])(?:(?:-|\/|\,|#)(?:[1-7]))?(?:L)?)*|\?|\*|(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?(?:,(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?)*)(|\s)+(\?|\*|(?:|\d{4})(?:(?:-|\/|\,)(?:|\d{4}))?(?:,(?:|\d{4})(?:(?:-|\/|\,)(?:|\d{4}))?)*))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*($|#|\\w+\\s*=|(\\?|\\*|(?:[0-5]?\\d)(?:(?:-|\\\/|\\,)(?:[0-5]?\\d))?(?:,(?:[0-5]?\\d)(?:(?:-|\\\/|\\,)(?:[0-5]?\\d))?)*)\\s+(\\?|\\*|(?:[0-5]?(?:\\d|\\*))(?:(?:-|\\\/|\\,)(?:[0-5]?\\d))?(?:,(?:[0-5]?\\d)(?:(?:-|\\\/|\\,)(?:[0-5]?\\d))?)*)\\s+(\\?|\\*|(?:[01]?(?:\\d|\\*)|2[0-3])(?:(?:-|\\\/|\\,)(?:[01]?\\d|2[0-3]))?(?:,(?:[01]?\\d|2[0-3])(?:(?:-|\\\/|\\,)(?:[01]?\\d|2[0-3]))?)*)\\s+(\\?|\\*|(?:0?[1-9]|[12]\\d|3[01]|\\*)(?:(?:-|\\\/|\\,)(?:0?[1-9]|[12]\\d|3[01]))?(?:,(?:0?[1-9]|[12]\\d|3[01])(?:(?:-|\\\/|\\,)(?:0?[1-9]|[12]\\d|3[01]))?)*|(?:L)|(?:LW)|(?:L-(?:[0-9]|1\\d|2\\d|30))|(?:\\dW|1\\dW))\\s+(\\?|\\*|(?:[1-9]|1[012])(?:(?:-|\\\/|\\,)(?:[1-9]|1[012]))?(?:L|W)?(?:,(?:[1-9]|1[012])(?:(?:-|\\\/|\\,)(?:[1-9]|1[012]))?(?:L|W)?)*|\\?|\\*|(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?(?:,(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)*)\\s+(\\?|\\*|(?:[1-7])(?:(?:-|\\\/|\\,|#)(?:[1-7]))?(?:L)?(?:,(?:[1-7])(?:(?:-|\\\/|\\,|#)(?:[1-7]))?(?:L)?)*|\\?|\\*|(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?(?:,(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?)*)(|\\s)+(\\?|\\*|(?:|\\d{4})(?:(?:-|\\\/|\\,)(?:|\\d{4}))?(?:,(?:|\\d{4})(?:(?:-|\\\/|\\,)(?:|\\d{4}))?)*))$', 'gm')
const str = `* * * ? * *
0 0/1 * * * ?
0/5 14,18,3-39,52 * ? JAN,MAR,SEP MON-FRI 2002-2010
0 * * ? * *
0 */2 * ? * *
0 1/2 * ? * *
0 */3 * ? * *
0 */4 * ? * *
0 */5 * ? * *
0 */10 * ? * *
0 */15 * ? * *
0 */30 * ? * *
0 15,30,45 * ? * *
0 0 * ? * *
0 0 */2 ? * *
0 0 0/2 ? * *
0 0 1/2 ? * *
0 0 */3 ? * *
0 0 */4 ? * *
0 0 */6 ? * *
0 0 */8 ? * *
0 0 */12 ? * *
0 0 0 * * ?
0 0 1 * * ?
0 0 6 * * ?
0 0 12 * * ?
0 0 12 ? * SUN
0 0 12 ? * MON
0 0 12 ? * TUE
0 0 12 ? * WED
0 0 12 ? * THU
0 0 12 ? * FRI
0 0 12 ? * SAT
0 0 12 ? * MON-FRI
0 0 12 ? * SUN,SAT
0 0 12 */7 * ?
0 0 12 1 * ?
0 0 12 2 * ?
0 0 12 15 * ?
0 0 12 1/2 * ?
0 0 12 1/4 * ?
0 0 12 L * ?
0 0 12 L-2 * ?
0 0 12 L-12 * ?
0 0 12 L-22 * ?
0 0 12 L-30 * ?
0 0 12 LW * ?
0 0 12 1W * ?
0 0 12 15W * ?
0 0 12 ? * 2#1
0 0 12 ? * 6#1
0 0 12 ? * 2#2
0 0 12 ? * 5#3
0 0 12 ? JAN *
0 0 12 ? JUN *
0 0 12 ? JAN,JUN *
0 0 12 ? DEC *
0 0 12 ? JAN,FEB,MAR,APR *
0 0 12 ? 9-12 *
0 1 0 ? * 7
0 59 23 ? * 7,2,1,5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}