import re
regex = re.compile(r"^\s*($|#|\w+\s*=|(\?|\*|(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?(?:,(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?)*)\s+(\?|\*|(?:[0-5]?(?:\d|\*))(?:(?:-|\/|\,)(?:[0-5]?\d))?(?:,(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?)*)\s+(\?|\*|(?:[01]?(?:\d|\*)|2[0-3])(?:(?:-|\/|\,)(?:[01]?\d|2[0-3]))?(?:,(?:[01]?\d|2[0-3])(?:(?:-|\/|\,)(?:[01]?\d|2[0-3]))?)*)\s+(\?|\*|(?:0?[1-9]|[12]\d|3[01]|\*)(?:(?:-|\/|\,)(?:0?[1-9]|[12]\d|3[01]))?(?:,(?:0?[1-9]|[12]\d|3[01])(?:(?:-|\/|\,)(?:0?[1-9]|[12]\d|3[01]))?)*|(?:L)|(?:LW)|(?:L-(?:[0-9]|1\d|2\d|30))|(?:\dW|1\dW))\s+(\?|\*|(?:[1-9]|1[012])(?:(?:-|\/|\,)(?:[1-9]|1[012]))?(?:L|W)?(?:,(?:[1-9]|1[012])(?:(?:-|\/|\,)(?:[1-9]|1[012]))?(?:L|W)?)*|\?|\*|(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?(?:,(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)*)\s+(\?|\*|(?:[1-7])(?:(?:-|\/|\,|#)(?:[1-7]))?(?:L)?(?:,(?:[1-7])(?:(?:-|\/|\,|#)(?:[1-7]))?(?:L)?)*|\?|\*|(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?(?:,(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?)*)(|\s)+(\?|\*|(?:|\d{4})(?:(?:-|\/|\,)(?:|\d{4}))?(?:,(?:|\d{4})(?:(?:-|\/|\,)(?:|\d{4}))?)*))$", flags=re.MULTILINE)
test_str = ("* * * ? * *\n"
"0 0/1 * * * ?\n"
"0/5 14,18,3-39,52 * ? JAN,MAR,SEP MON-FRI 2002-2010\n"
"0 * * ? * *\n"
"0 */2 * ? * *\n"
"0 1/2 * ? * *\n"
"0 */3 * ? * *\n"
"0 */4 * ? * *\n"
"0 */5 * ? * *\n"
"0 */10 * ? * *\n"
"0 */15 * ? * *\n"
"0 */30 * ? * *\n"
"0 15,30,45 * ? * *\n"
"0 0 * ? * *\n"
"0 0 */2 ? * *\n"
"0 0 0/2 ? * *\n"
"0 0 1/2 ? * *\n"
"0 0 */3 ? * *\n"
"0 0 */4 ? * *\n"
"0 0 */6 ? * *\n"
"0 0 */8 ? * *\n"
"0 0 */12 ? * *\n"
"0 0 0 * * ?\n"
"0 0 1 * * ?\n"
"0 0 6 * * ?\n"
"0 0 12 * * ?\n"
"0 0 12 ? * SUN\n"
"0 0 12 ? * MON\n"
"0 0 12 ? * TUE\n"
"0 0 12 ? * WED\n"
"0 0 12 ? * THU\n"
"0 0 12 ? * FRI\n"
"0 0 12 ? * SAT\n"
"0 0 12 ? * MON-FRI\n"
"0 0 12 ? * SUN,SAT\n"
"0 0 12 */7 * ?\n"
"0 0 12 1 * ?\n"
"0 0 12 2 * ?\n"
"0 0 12 15 * ?\n"
"0 0 12 1/2 * ?\n"
"0 0 12 1/4 * ?\n"
"0 0 12 L * ?\n"
"0 0 12 L-2 * ?\n"
"0 0 12 L-12 * ?\n"
"0 0 12 L-22 * ?\n"
"0 0 12 L-30 * ?\n"
"0 0 12 LW * ?\n"
"0 0 12 1W * ?\n"
"0 0 12 15W * ?\n"
"0 0 12 ? * 2#1\n"
"0 0 12 ? * 6#1\n"
"0 0 12 ? * 2#2\n"
"0 0 12 ? * 5#3\n"
"0 0 12 ? JAN *\n"
"0 0 12 ? JUN *\n"
"0 0 12 ? JAN,JUN *\n"
"0 0 12 ? DEC *\n"
"0 0 12 ? JAN,FEB,MAR,APR *\n"
"0 0 12 ? 9-12 *\n"
"0 1 0 ? * 7\n"
"0 59 23 ? * 7,2,1,5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")