$re = '/(?=<div)(?=[\s\S]*?2018)[\s\S]*?(?:<\/div>)/m';
$str = '<div> ffjdklfjdklfjs 2023 ddddd </div> sfsfsfsfsf
<div> hkh/ <> -%=:;.éj
hjk 2018 / dsqkdlmqs </div> fdfdfd </div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);