re = /(?=<div)(?=[\s\S]*?2018)[\s\S]*?(?:<\/div>)/m
str = '<div> ffjdklfjdklfjs 2023 ddddd </div> sfsfsfsfsf
<div> hkh/ <> -%=:;.éj
hjk 2018 / dsqkdlmqs </div> fdfdfd </div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end