re = /(\r?\n)\s*(?=\r?\n)(?=[^\s]+?|$)/m
str = 'var массив = [
function(){
var слой = document.createElement("div")
слой.id = "ID"
document.body.appendChild(слой)
слой.style.width = "200px"
слой.style.height = "200px"
слой.style.position = "absolute"
слой.style.left = "0%"
слой.style.top = "0%"
слой.style.filter = "drop-shadow(1px 1px 5px Yellow)"
слой.style.boxShadow = "1px 1px 5px IndianRed"
return 1000},
function(){
элемент = ID
элемент.style.transition = "all 1s cubic-bezier(0.5,-0.5,0.5,1.5) "
элемент.style.position = "absolute"
элемент.style.left = "33%"
элемент.style.top = "33%"
return 1000},
]'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result