const regex = new RegExp('([\\\\'"`])\\s*\\1\\s*', 'gm')
const str = `hey how ' ' is the \` \` what are '' you doing \`\` how is everything`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);