$re = '/([\'"`])\s*\1\s*/m';
$str = 'hey how \' \' is the ` ` what are \'\' you doing `` how is everything';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;