#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!<!--.+)src=".+\.js""
Local $sString = "<!------<script type="text/javascript" src="js/Shop.js"></script> -->" & @CRLF & _
"<!----<script type="text/javascript" src="js/Shop.js"></script> -->" & @CRLF & _
"<script type="text/javascript" src="jquery.serialize-object.js"></script><!---->" & @CRLF & _
"<script type="text/javascript" src="jquery.serialize-object.js"></script><!-- a comment -- afterwards -->" & @CRLF & _
"<script type="text/javascript" src="jquery.serialize-object.js"></script><!-- a comment starting but not ending" & @CRLF & _
"-- afterwards -->" & @CRLF & _
"<script type="text/javascript" src="jquery.serialize-object.js"></script>" & @CRLF & _
"<script type="text/javascript" src="jquery.cookie.js"></script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")