import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!<!--.+)src=\".+\\.js\"";
final String string = "<!------<script type=\"text/javascript\" src=\"js/Shop.js\"></script> -->\n"
+ "<!----<script type=\"text/javascript\" src=\"js/Shop.js\"></script> -->\n"
+ "<script type=\"text/javascript\" src=\"jquery.serialize-object.js\"></script><!---->\n"
+ "<script type=\"text/javascript\" src=\"jquery.serialize-object.js\"></script><!-- a comment -- afterwards -->\n"
+ "<script type=\"text/javascript\" src=\"jquery.serialize-object.js\"></script><!-- a comment starting but not ending\n"
+ "-- afterwards -->\n"
+ "<script type=\"text/javascript\" src=\"jquery.serialize-object.js\"></script>\n"
+ "<script type=\"text/javascript\" src=\"jquery.cookie.js\"></script>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}