#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(at \d{2}\:\d{2}\:\d{2} CET \D{3} \D{3} \d+ \d{4} by \D{6}).*\R.*\1"
Local $sString = "Current configuration : 11518 bytes" & @CRLF & _
"!" & @CRLF & _
"! Last configuration change at 12:48:00 CET Thu Jan 3 2019 by admjos" & @CRLF & _
"! NVRAM config last updated at 12:48:00 CET Thu Jan 3 2019 by admjos" & @CRLF & _
"!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Current configuration : 11524 bytes" & @CRLF & _
"!" & @CRLF & _
"! Last configuration change at 10:40:46 CET Wed Jan 16 2019 by admjos" & @CRLF & _
"! NVRAM config last updated at 12:48:02 CET Thu Jan 3 2019 by admjos" & @CRLF & _
"!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")