import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(at \\d{2}\\:\\d{2}\\:\\d{2} CET \\D{3} \\D{3} \\d+ \\d{4} by \\D{6}).*\\R.*\\1";
final String string = "Current configuration : 11518 bytes\n"
+ "!\n"
+ "! Last configuration change at 12:48:00 CET Thu Jan 3 2019 by admjos\n"
+ "! NVRAM config last updated at 12:48:00 CET Thu Jan 3 2019 by admjos\n"
+ "!\n\n\n"
+ "Current configuration : 11524 bytes\n"
+ "!\n"
+ "! Last configuration change at 10:40:46 CET Wed Jan 16 2019 by admjos\n"
+ "! NVRAM config last updated at 12:48:02 CET Thu Jan 3 2019 by admjos\n"
+ "!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}