#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)--?" & @CRLF & _
"(?P<key>\w+)" & @CRLF & _
"(?|" & @CRLF & _
" =(?P<value>[^-\s?"]+)" & @CRLF & _
" |" & @CRLF & _
" \h+"(?P<value>.*?)(?<!\\)"" & @CRLF & _
" |" & @CRLF & _
" \h+(?P<value>\H+)" & @CRLF & _
")"
Local $sString = "-Parameter1=1234 -Parameter2=38518 -param3 "Test \"escaped\"" -param4 10 -param5 0 -param6 "TT" -param7 "Seven" -param8 "secret" "-SuperParam9=4857?--SuperParam10=123""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")