package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`--?
(?P<key>\w+)
(?|
=(?P<value>[^-\s?"]+)
|
\h+"(?P<value>.*?)(?<!\\)"
|
\h+(?P<value>\H+)
)`)
var str = `-Parameter1=1234 -Parameter2=38518 -param3 "Test \"escaped\"" -param4 10 -param5 0 -param6 "TT" -param7 "Seven" -param8 "secret" "-SuperParam9=4857?--SuperParam10=123"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}