$re = '/^(?=[A-Z\d,/]{10,22}$)[A-Z]{2,}[A-Z\d,/]*\d$/m';
$str = 'NEV2297075
WB/03/001/585269
WB/03/HK/585065';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);