re = /^(?=[A-Z\d,\/]{10,22}$)[A-Z]{2,}[A-Z\d,\/]*\d$/m
str = 'NEV2297075
WB/03/001/585269
WB/03/HK/585065'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end