package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+_topoaa|[0-9]+_flexref)`)
var str = `0_topoaa
101_flexref
2_nothing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}