$re = '/([0-9]+_topoaa|[0-9]+_flexref)/m';
$str = '0_topoaa
101_flexref
2_nothing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);