$re = '/^({)?(?(1)|(\()?)[0-9A-F]{8}(-)?([0-9A-F]{4}(?(3)-)){3}[0-9A-F]{12}(?(1)}|(?(2)\)))$/i';
$str = 'CA761232 ED42 11CE BACD 00AA0057B223
CA761232-ED42-11CE-BACD-00AA0057B223';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);