import re
regex = re.compile(r"^({)?(?(1)|(\()?)[0-9A-F]{8}(-)?([0-9A-F]{4}(?(3)-)){3}[0-9A-F]{12}(?(1)}|(?(2)\)))$", flags=re.IGNORECASE)
test_str = ("CA761232 ED42 11CE BACD 00AA0057B223\n\n"
"CA761232-ED42-11CE-BACD-00AA0057B223")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")