package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bCity\s+of\s+([A-Z][^\s,]+(?:\s+[A-Z][^\s,]+)*)`)
var str = `0. ALL that certain piece, parcel or tract of land situate, lying and being in the City
of Travelers Rest, County of Greenville, State of South Carolina
1. Townes Street on the West, in the City of Greenville, County of Greenville, State of
South Carolina
2. State of South Carolina, County of Greenville, City of Hampton on the southern side`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}