import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bCity\\s+of\\s+([A-Z][^\\s,]+(?:\\s+[A-Z][^\\s,]+)*)";
final String string = "0. ALL that certain piece, parcel or tract of land situate, lying and being in the City \n"
+ " of Travelers Rest, County of Greenville, State of South Carolina\n\n"
+ "1. Townes Street on the West, in the City of Greenville, County of Greenville, State of \n"
+ " South Carolina\n\n"
+ "2. State of South Carolina, County of Greenville, City of Hampton on the southern side";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}