using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D+(?:(?:\d{1,3}|\d{5,})(?!\d)\D*)*";
string substitution = @"";
string input = @"Film_relase_date:1970_films_by_20th_Century_Fox
Film_relase_date:19720_films_by_20th_Century_Fox
Film_relase_date:197_films_by_20th_Century_Fox
test1test1234test1234567890testa1a2a3a4444a55555a0000000000000000000000000000000000000000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}