import re
regex = re.compile(r"\D+(?:(?:\d{1,3}|\d{5,})(?!\d)\D*)*", flags=re.MULTILINE)
test_str = ("Film_relase_date:1970_films_by_20th_Century_Fox\n"
"Film_relase_date:19720_films_by_20th_Century_Fox\n"
"Film_relase_date:197_films_by_20th_Century_Fox\n"
"test1test1234test1234567890testa1a2a3a4444a55555a0000000000000000000000000000000000000000")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)