$re = '/\B\.\w+,? ?/';
$str = 'ad, ghost, hg, .hi, jk, find.jpg, dam.ark, haji, jive.pdf, .find, home, .war, .milk, raj, .ker';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;