import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^()\\n]+\\([^()]*\\)\\s*\n"
+ "\\{\n"
+ " (?:[^\\{\\}]*|(?R))+\n"
+ "\\}";
final String string = "int firt(){\n"
+ " if () { \n\n"
+ " }\n"
+ "}\n\n"
+ "customtype second(){\n"
+ " if () { \n\n"
+ " }\n"
+ " for(){ // some totally valid curly brace here: }{\n\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}