$re = '~^[^()\n]+\([^()]*\)\s*
\{
(?:[^{}]*|(?R))+
\}~mx';
$str = 'int firt(){
if () {
}
}
customtype second(){
if () {
}
for(){ // some totally valid curly brace here: }{
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);