using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\byes\b.+\byes\b)(?=.*\bor\b).+";
string input = @"yes or yes
no or yes
yes or no
maybe yes or yes
yes maybe or yes
maybe yes maybe yes maybe or";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}