import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\byes\\b.+\\byes\\b)(?=.*\\bor\\b).+";
final String string = "yes or yes\n"
+ "no or yes\n"
+ "yes or no\n"
+ "maybe yes or yes\n"
+ "yes maybe or yes\n"
+ "maybe yes maybe yes maybe or";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}