import re
regex = re.compile(r"(([^a]|a[^)])*)a\)")
test_str = ("pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta\n\n"
"pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunt\n\n"
" aa) resposta a\n\n"
" b) resposta b \n\n"
" c) resposta c\n\n"
" d) resposta d\n\n"
" e) resposta e")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)