import re
regex = re.compile(r"^\d{1,2}([ -.\/])(\d{1,2}|[a-zA-z]{3,15})(?1)\d{2,4}( \d{2}:\d{2}(:\d{2}([.:]\d)?)?)?$|^(\d{1,2}|[a-zA-z]{3,15})([ -.\/])\d{1,2}(?7)\d{2,4}( \d{2}:\d{2}(:\d{2}([.:]\d)?)?)?$|^\d{2,4}([ -.\/])(\d{1,2}|[a-zA-z]{3,15})\d{1,2}(?11)( \d{2}:\d{2}(:\d{2}([.:]\d)?)?)?$", flags=re.MULTILINE)
test_str = ("23/02/1993\n"
"23-02/1993\n"
"23-fev-1993\n"
"fev-23-1993\n"
"fev.02.93\n"
"28-OCT-90\n"
"28-OCT-1990\n"
"10/28/90\n"
"10/28/1990\n"
"28.10.90\n"
"dd.mm.yyyy\n"
"28.10.1990\n"
"90/10/28\n"
"yyyy/mm/dd\n"
"1990/10/28\n"
"4 Q 1990\n"
"OCT 90\n"
"OCT 1990\n"
"01:02\n"
"01:02:34.75\n"
"02:34\n"
"02:34.75\n"
"20 08:03\n"
"20 08:03:00\n"
"20-JUN-1990 08:03\n"
"20-JUN-1990 08:03:00\n"
"1990-06-20 08:03\n"
"1990-06-20 08:03:00.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")