const regex = new RegExp('submitted by .+ ([a-zA-Z\\'\\-_]+)( [a-zA-Z\\'\\-_]+\\.)? :', 'gm')
const str = `The following records request has been submitted by Bryan Trummer :
The following records request has been submitted by Ray Parker Jr. :
The following records request has been submitted by William Stanley Preston, Esq. :
The following records request has been submitted by Marshall Bruce Mathers III :
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}