#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<major>\d+)(?:\.(?P<minor>\d+)(?:\.(?P<build>\d+)(?:\.(?P<revision>\d+))?)?)?(?:-(?P<prerelease>\w+)(?:[-\.](?P<version>\d+))?)?$"
Local $sString = "1.0.10123.0" & @CRLF & _
"1.0.10123.0-preview" & @CRLF & _
"1.0.10123.0-beta-1" & @CRLF & _
"1.0.10123.0-beta.2" & @CRLF & _
"0.9-beta-2" & @CRLF & _
"2.1.0" & @CRLF & _
"2.1.1" & @CRLF & _
"2.1.1-preview" & @CRLF & _
"2.1.1-beta.1" & @CRLF & _
"2.1.1-rc-4" & @CRLF & _
"1.8.9" & @CRLF & _
"2.5.1" & @CRLF & _
"5.2.1" & @CRLF & _
"6.5" & @CRLF & _
"" & @CRLF & _
"11.5" & @CRLF & _
"1.16" & @CRLF & _
"5.4.1.1" & @CRLF & _
"5.4.1.1" & @CRLF & _
"5.4.1.1" & @CRLF & _
"1.4" & @CRLF & _
"1.4.2" & @CRLF & _
"1.9.1.8" & @CRLF & _
"1.6.37" & @CRLF & _
"3.1" & @CRLF & _
"" & @CRLF & _
"15" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"15.112.1" & @CRLF & _
"17.14.15" & @CRLF & _
"17.14.15" & @CRLF & _
"17.8.8" & @CRLF & _
"1.1.2" & @CRLF & _
"1.1.2" & @CRLF & _
"1.1.1" & @CRLF & _
"15" & @CRLF & _
"13.0.3" & @CRLF & _
"5.4" & @CRLF & _
"15.0.2" & @CRLF & _
"15.0.2" & @CRLF & _
"15.0.2" & @CRLF & _
"15" & @CRLF & _
"1.3.6" & @CRLF & _
"1.1.1" & @CRLF & _
"8.5.2" & @CRLF & _
"3.0.0" & @CRLF & _
"9.0.107" & @CRLF & _
"9.0.537" & @CRLF & _
"9.0.537" & @CRLF & _
"9.0.537" & @CRLF & _
"4.2.0" & @CRLF & _
"9.0.0" & @CRLF & _
"9.0.1" & @CRLF & _
"9.0.0" & @CRLF & _
"6.0.0" & @CRLF & _
"3.0.0" & @CRLF & _
"7.0.0" & @CRLF & _
"3.0.0" & @CRLF & _
"1.8.11" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1.0.119" & @CRLF & _
"5.2.3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"6.1" & @CRLF & _
"6.1" & @CRLF & _
"22" & @CRLF & _
"1" & @CRLF & _
"1.0.3240.44" & @CRLF & _
"3.5.5" & @CRLF & _
"3.5.5-preview" & @CRLF & _
"3.5.5-preview.1" & @CRLF & _
"3.5.5-preview-2" & @CRLF & _
"3.2" & @CRLF & _
"3.2-beta"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")