import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<major>\\d+)(?:\\.(?P<minor>\\d+)(?:\\.(?P<build>\\d+)(?:\\.(?P<revision>\\d+))?)?)?(?:-(?P<prerelease>\\w+)(?:[-\\.](?P<version>\\d+))?)?$";
final String string = "1.0.10123.0\n"
+ "1.0.10123.0-preview\n"
+ "1.0.10123.0-beta-1\n"
+ "1.0.10123.0-beta.2\n"
+ "0.9-beta-2\n"
+ "2.1.0\n"
+ "2.1.1\n"
+ "2.1.1-preview\n"
+ "2.1.1-beta.1\n"
+ "2.1.1-rc-4\n"
+ "1.8.9\n"
+ "2.5.1\n"
+ "5.2.1\n"
+ "6.5\n\n"
+ "11.5\n"
+ "1.16\n"
+ "5.4.1.1\n"
+ "5.4.1.1\n"
+ "5.4.1.1\n"
+ "1.4\n"
+ "1.4.2\n"
+ "1.9.1.8\n"
+ "1.6.37\n"
+ "3.1\n\n"
+ "15\n\n"
+ "2\n\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "15.112.1\n"
+ "17.14.15\n"
+ "17.14.15\n"
+ "17.8.8\n"
+ "1.1.2\n"
+ "1.1.2\n"
+ "1.1.1\n"
+ "15\n"
+ "13.0.3\n"
+ "5.4\n"
+ "15.0.2\n"
+ "15.0.2\n"
+ "15.0.2\n"
+ "15\n"
+ "1.3.6\n"
+ "1.1.1\n"
+ "8.5.2\n"
+ "3.0.0\n"
+ "9.0.107\n"
+ "9.0.537\n"
+ "9.0.537\n"
+ "9.0.537\n"
+ "4.2.0\n"
+ "9.0.0\n"
+ "9.0.1\n"
+ "9.0.0\n"
+ "6.0.0\n"
+ "3.0.0\n"
+ "7.0.0\n"
+ "3.0.0\n"
+ "1.8.11\n\n\n"
+ "1.0.119\n"
+ "5.2.3\n\n\n"
+ "6.1\n"
+ "6.1\n"
+ "22\n"
+ "1\n"
+ "1.0.3240.44\n"
+ "3.5.5\n"
+ "3.5.5-preview\n"
+ "3.5.5-preview.1\n"
+ "3.5.5-preview-2\n"
+ "3.2\n"
+ "3.2-beta";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}