#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Date\s*:\s*(?'dtheure_deb_interv'.*?)\s*Site\s*:\s*.*\s*BATIMENT\s*:\s*(?'ins_libl'.*?)\s*(?:LOCAL\s*:\s*(?'apt_localisation'.*?)\s*)?CONTACT\s*:\s*(?'apt_nom'.*?)\s*TELEPHONE\s*:\s*(?'apt_telephone'.*?)\s*SYMPTOME\s*:\s*(?'tsy_lib'.*?)\s*QUALIFICATION\s*:\s*(?'qsy_lib'.*?)\s*N\xB0.*CIRAD\s*:\s*(?'num_externe'.*?)\s*TITRE\s*:\s*(?'commentaire_externe'.*?)\s*DESCRIPTIF"
Local $sString = "DEMANDE D'INTERVENTION, Date : 30/04/2019 Site : 010 - Lavalette BATIMENT : Serre 16 CONTACT : loge_lavalette@cirad.fr TELEPHONE : ? SYMPTOME : Chauffage QUALIFICATION : Alarme / défaut N° bon CIRAD : DI-34-028312 TITRE : Alarme 203 T°C cell 6 serre 16 DESCRIPTIF : cofely avisé "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")