import Foundation
let pattern = #"Date\s*:\s*(?'dtheure_deb_interv'.*?)\s*Site\s*:\s*.*\s*BATIMENT\s*:\s*(?'ins_libl'.*?)\s*(?:LOCAL\s*:\s*(?'apt_localisation'.*?)\s*)?CONTACT\s*:\s*(?'apt_nom'.*?)\s*TELEPHONE\s*:\s*(?'apt_telephone'.*?)\s*SYMPTOME\s*:\s*(?'tsy_lib'.*?)\s*QUALIFICATION\s*:\s*(?'qsy_lib'.*?)\s*N\xB0.*CIRAD\s*:\s*(?'num_externe'.*?)\s*TITRE\s*:\s*(?'commentaire_externe'.*?)\s*DESCRIPTIF"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"DEMANDE D'INTERVENTION, Date : 30/04/2019 Site : 010 - Lavalette BATIMENT : Serre 16 CONTACT : loge_lavalette@cirad.fr TELEPHONE : ? SYMPTOME : Chauffage QUALIFICATION : Alarme / défaut N° bon CIRAD : DI-34-028312 TITRE : Alarme 203 T°C cell 6 serre 16 DESCRIPTIF : cofely avisé "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)