#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}\.\d{3}Z) (?<level>\w+) (?<servicename>(\w+|\-))\[(?<uniquething>[A-F\d]+)\] \[(?<function>Originator@\d+) sub=(?<subsys>\S+)\] (?<body>.*)$"
Local $sString = "2017-05-04T14:46:44.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Logging uses fast path: false" & @CRLF & _
"2017-05-04T14:46:45.163Z Section for PyVsanMOPropProvider, pid=68004, version=0.1, build=5310541, option=Release" & @CRLF & _
"2017-05-04T14:46:46Z mark: storage-path-claim-completed" & @CRLF & _
"2017-05-04T14:46:47.163Z verbose vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Dumping early logs:" & @CRLF & _
"------ Early init logs start --------" & @CRLF & _
"2017-05-04T14:46:47.163Z info -[7AFFC9DB20] [Originator@6876 sub=Default] Glibc malloc guards disabled." & @CRLF & _
"2017-05-04T14:46:47.163Z info -[7AFFC9DB20] [Originator@6876 sub=Default] Initialized SystemFactory" & @CRLF & _
"------ Early init logs end --------" & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Logging uses fast path: false" & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] The bora/lib logs WILL be handled by VmaCore" & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Initialized channel manager" & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Current working directory: /var/log/vmware" & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=ThreadPool] Catch work item exceptions disabled." & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=FairScheduler] Priority level 4 is now active." & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=WorkQueue.vmacoreDefaultIOCompletionQueue] Created: WorkQueue.vmacoreDefaultIOCompletionQueue, type = fair, priority = 4 , itemWeight = 1" & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=FairScheduler] Priority level 8 is now active." & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=WorkQueue.vmacoreDefaultIOQueue] Created: WorkQueue.vmacoreDefaultIOQueue, type = fair, priority = 8 , itemWeight = 1" & @CRLF & _
"2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=FairScheduler] Priority level 16 is now active."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")